import Foundation
let pattern = #"<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(instagram\.com)\/(p\/)?(?<photoID>[A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)?<\/p>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Best case
<p>https://www.instagram.com/p/B9XK4J3jVui/</p>
Whitespace
<p>
https://www.instagram.com/p/B9XK4J3jVui/
</p>
Protocol variations
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>www.instagram.com/p/B9XK4J3jVui/</p>
<p>instagram.com/p/B9XK4J3jVui/</p>
Trailing slash or not
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>http://www.instagram.com/p/B9XK4J3jVui</p>
Linked
<p><a href="http://www.instagram.com/p/B9XK4J3jVui/">http://www.instagram.com/p/B9XK4J3jVui/</a></p>
<p>
<a href="http://www.instagram.com/p/B9XK4J3jVui/">
http://www.instagram.com/p/B9XK4J3jVui/
</a>
</p>
Extraneous URL params
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar</p>
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar&baz=buzz</p>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)