import re
regex = re.compile(r"<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(instagram\.com)\/(p\/)?(?<photoID>[A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)?<\/p>")
test_str = ("Best case\n"
"<p>https://www.instagram.com/p/B9XK4J3jVui/</p>\n\n"
"Whitespace\n"
"<p>\n"
" https://www.instagram.com/p/B9XK4J3jVui/\n"
"</p>\n\n"
"Protocol variations\n"
"<p>http://www.instagram.com/p/B9XK4J3jVui/</p>\n"
"<p>www.instagram.com/p/B9XK4J3jVui/</p>\n"
"<p>instagram.com/p/B9XK4J3jVui/</p>\n\n"
"Trailing slash or not\n"
"<p>http://www.instagram.com/p/B9XK4J3jVui/</p>\n"
"<p>http://www.instagram.com/p/B9XK4J3jVui</p>\n\n\n"
"Linked\n"
"<p><a href=\"http://www.instagram.com/p/B9XK4J3jVui/\">http://www.instagram.com/p/B9XK4J3jVui/</a></p>\n"
"<p>\n"
" <a href=\"http://www.instagram.com/p/B9XK4J3jVui/\">\n"
" http://www.instagram.com/p/B9XK4J3jVui/\n"
" </a>\n"
"</p>\n\n"
"Extraneous URL params\n"
"<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar</p>\n"
"<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar&baz=buzz</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")