// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(instagram\.com)\/(p\/)?(?<photoID>[A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)?<\/p>").unwrap();
let string = "Best case
<p>https://www.instagram.com/p/B9XK4J3jVui/</p>
Whitespace
<p>
https://www.instagram.com/p/B9XK4J3jVui/
</p>
Protocol variations
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>www.instagram.com/p/B9XK4J3jVui/</p>
<p>instagram.com/p/B9XK4J3jVui/</p>
Trailing slash or not
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>http://www.instagram.com/p/B9XK4J3jVui</p>
Linked
<p><a href=\"http://www.instagram.com/p/B9XK4J3jVui/\">http://www.instagram.com/p/B9XK4J3jVui/</a></p>
<p>
<a href=\"http://www.instagram.com/p/B9XK4J3jVui/\">
http://www.instagram.com/p/B9XK4J3jVui/
</a>
</p>
Extraneous URL params
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar</p>
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar&baz=buzz</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}