#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(bad|wrong)\b"
Local $sString = "bad bads man wrong" & @CRLF & _
"bads man wrong" & @CRLF & _
"abad man wrong" & @CRLF & _
"abad man wrongs" & @CRLF & _
"abad man awrong" & @CRLF & _
"bad man" & @CRLF & _
"wrong man" & @CRLF & _
"badge text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")