import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(bad|wrong)\\b";
final String string = "bad bads man wrong\n"
+ "bads man wrong\n"
+ "abad man wrong\n"
+ "abad man wrongs\n"
+ "abad man awrong\n"
+ "bad man\n"
+ "wrong man\n"
+ "badge text";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}