package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(bad|wrong)\b`)
var str = `bad bads man wrong
bads man wrong
abad man wrong
abad man wrongs
abad man awrong
bad man
wrong man
badge text`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}