re = /\b(bad|wrong)\b/m
str = 'bad bads man wrong
bads man wrong
abad man wrong
abad man wrongs
abad man awrong
bad man
wrong man
badge text'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end