using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(bad|wrong)\b";
string input = @"bad bads man wrong
bads man wrong
abad man wrong
abad man wrongs
abad man awrong
bad man
wrong man
badge text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}