const regex = /\b(bad|wrong)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(bad|wrong)\\b', 'gm')
const str = `bad bads man wrong
bads man wrong
abad man wrong
abad man wrongs
abad man awrong
bad man
wrong man
badge text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}