import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:\\b(?:[1-9]|[01]\\d|2[0-3])):(?:[0-5]\\d)(?:\\s*[AaPp][mM])?(?!([3-9]\\d+:\\d+)))";
final String string = "MUST MATCH\n\n"
+ "9:30 AM - 10:30 AM\n"
+ "5:50AM-6:25PM\n"
+ "18:20-21:30\n"
+ "7:30-8:30\n"
+ "11:30-13:12\n"
+ "23:00-00:00\n\n"
+ "MUST NOT MATCH\n"
+ "33:85 - 99:20\n"
+ "420:69 - 69 :420\n"
+ "20:45AM-52:20\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}