use strict;
my $str = 'MUST MATCH
9:30 AM - 10:30 AM
5:50AM-6:25PM
18:20-21:30
7:30-8:30
11:30-13:12
23:00-00:00
MUST NOT MATCH
33:85 - 99:20
420:69 - 69 :420
20:45AM-52:20
';
my $regex = qr/((?:\b(?:[1-9]|[01]\d|2[0-3])):(?:[0-5]\d)(?:\s*[AaPp][mM])?(?!([3-9]\d+:\d+)))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}