re = /((?:\b(?:[1-9]|[01]\d|2[0-3])):(?:[0-5]\d)(?:\s*[AaPp][mM])?(?!([3-9]\d+:\d+)))/
str = 'MUST MATCH
9:30 AM - 10:30 AM
5:50AM-6:25PM
18:20-21:30
7:30-8:30
11:30-13:12
23:00-00:00
MUST NOT MATCH
33:85 - 99:20
420:69 - 69 :420
20:45AM-52:20
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end