# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:\b(?:[1-9]|[01]\d|2[0-3])):(?:[0-5]\d)(?:\s*[AaPp][mM])?(?!([3-9]\d+:\d+)))"
test_str = ("MUST MATCH\n\n"
"9:30 AM - 10:30 AM\n"
"5:50AM-6:25PM\n"
"18:20-21:30\n"
"7:30-8:30\n"
"11:30-13:12\n"
"23:00-00:00\n\n"
"MUST NOT MATCH\n"
"33:85 - 99:20\n"
"420:69 - 69 :420\n"
"20:45AM-52:20\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.