const regex = /((?:\b(?:[1-9]|[01]\d|2[0-3])):(?:[0-5]\d)(?:\s*[AaPp][mM])?(?!([3-9]\d+:\d+)))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\b(?:[1-9]|[01]\\d|2[0-3])):(?:[0-5]\\d)(?:\\s*[AaPp][mM])?(?!([3-9]\\d+:\\d+)))', 'g')
const str = `MUST MATCH
9:30 AM - 10:30 AM
5:50AM-6:25PM
18:20-21:30
7:30-8:30
11:30-13:12
23:00-00:00
MUST NOT MATCH
33:85 - 99:20
420:69 - 69 :420
20:45AM-52:20
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}