import Foundation
let pattern = #"((?:\b(?:[1-9]|[01]\d|2[0-3])):(?:[0-5]\d)(?:\s*[AaPp][mM])?(?!([3-9]\d+:\d+)))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
MUST MATCH
9:30 AM - 10:30 AM
5:50AM-6:25PM
18:20-21:30
7:30-8:30
11:30-13:12
23:00-00:00
MUST NOT MATCH
33:85 - 99:20
420:69 - 69 :420
20:45AM-52:20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)