# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/-(?![a-z])/|/g;t' <<< "8-911-1234567
8-495-1-234-zzz"