use strict;
my $str = '8-911-1234567
8-495-1-234-zzz';
my $regex = qr/-(?![a-z])/p;
my $subst = '|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";