const regex = /-(?![a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-(?![a-z])', 'g')
const str = `8-911-1234567
8-495-1-234-zzz`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);