#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "-(?![a-z])"
Local $sString = "8-911-1234567" & @CRLF & _
"8-495-1-234-zzz"
Local $sSubst = "|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)