$re = '/-(?![a-z])/';
$str = '8-911-1234567
8-495-1-234-zzz';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;