import Foundation
let pattern = #"-(?![a-z])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
8-911-1234567
8-495-1-234-zzz
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)