#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(-\d*)?(?:,\s*\d+(-\d*)?)*$"
Local $sString = "1-5, 7, 33-48" & @CRLF & _
"1" & @CRLF & _
"1-5" & @CRLF & _
"1,3,5" & @CRLF & _
"3-" & @CRLF & _
"" & @CRLF & _
"Not matched:" & @CRLF & _
"1,,2" & @CRLF & _
"-1" & @CRLF & _
"1;4" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")