re = /^\d+(-\d*)?(?:,\s*\d+(-\d*)?)*$/m
str = '1-5, 7, 33-48
1
1-5
1,3,5
3-
Not matched:
1,,2
-1
1;4
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end