using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(-\d*)?(?:,\s*\d+(-\d*)?)*$";
string input = @"1-5, 7, 33-48
1
1-5
1,3,5
3-
Not matched:
1,,2
-1
1;4
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}