$re = '/^\d+(-\d*)?(?:,\s*\d+(-\d*)?)*$/m';
$str = '1-5, 7, 33-48
1
1-5
1,3,5
3-
Not matched:
1,,2
-1
1;4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);