const regex = /^\d+(-\d*)?(?:,\s*\d+(-\d*)?)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d+(-\\d*)?(?:,\\s*\\d+(-\\d*)?)*$', 'gm')
const str = `1-5, 7, 33-48
1
1-5
1,3,5
3-
Not matched:
1,,2
-1
1;4
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}