// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(-\d*)?(?:,\s*\d+(-\d*)?)*$").unwrap();
let string = "1-5, 7, 33-48
1
1-5
1,3,5
3-
Not matched:
1,,2
-1
1;4
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}