#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([+])?((\d)[.-]?)?[\s]?\(?(\d{3})\)?[.-]?[\s]?(\d{3})[.-]?[\s]?(\d{4,})"
Local $sString = "647-780-3056" & @CRLF & _
"6477803056" & @CRLF & _
"647.900.9000" & @CRLF & _
"+1-(412)-450-1234" & @CRLF & _
"+1.(323).444.4444" & @CRLF & _
"+2-(232)-334-0909" & @CRLF & _
"+133333333333" & @CRLF & _
"0016477803056" & @CRLF & _
"1 333 333 3333" & @CRLF & _
"+1 999 999 9999" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")