// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([+])?((\d)[.-]?)?[\s]?\(?(\d{3})\)?[.-]?[\s]?(\d{3})[.-]?[\s]?(\d{4,})").unwrap();
let string = "647-780-3056
6477803056
647.900.9000
+1-(412)-450-1234
+1.(323).444.4444
+2-(232)-334-0909
+133333333333
0016477803056
1 333 333 3333
+1 999 999 9999
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}