using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([+])?((\d)[.-]?)?[\s]?\(?(\d{3})\)?[.-]?[\s]?(\d{3})[.-]?[\s]?(\d{4,})";
string input = @"647-780-3056
6477803056
647.900.9000
+1-(412)-450-1234
+1.(323).444.4444
+2-(232)-334-0909
+133333333333
0016477803056
1 333 333 3333
+1 999 999 9999
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}