import re
regex = re.compile(r"([+])?((\d)[.-]?)?[\s]?\(?(\d{3})\)?[.-]?[\s]?(\d{3})[.-]?[\s]?(\d{4,})", flags=re.MULTILINE)
test_str = ("647-780-3056\n"
"6477803056\n"
"647.900.9000\n"
"+1-(412)-450-1234\n"
"+1.(323).444.4444\n"
"+2-(232)-334-0909\n"
"+133333333333\n"
"0016477803056\n"
"1 333 333 3333\n"
"+1 999 999 9999\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")