$re = '/([+])?((\d)[.-]?)?[\s]?\(?(\d{3})\)?[.-]?[\s]?(\d{3})[.-]?[\s]?(\d{4,})/m';
$str = '647-780-3056
6477803056
647.900.9000
+1-(412)-450-1234
+1.(323).444.4444
+2-(232)-334-0909
+133333333333
0016477803056
1 333 333 3333
+1 999 999 9999
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);