const regex = /([+])?((\d)[.-]?)?[\s]?\(?(\d{3})\)?[.-]?[\s]?(\d{3})[.-]?[\s]?(\d{4,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([+])?((\\d)[.-]?)?[\\s]?\\(?(\\d{3})\\)?[.-]?[\\s]?(\\d{3})[.-]?[\\s]?(\\d{4,})', 'gm')
const str = `647-780-3056
6477803056
647.900.9000
+1-(412)-450-1234
+1.(323).444.4444
+2-(232)-334-0909
+133333333333
0016477803056
1 333 333 3333
+1 999 999 9999
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}