#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b(\w+)\b.*\b\1\b)(?:another|contact|all)(?:,(?:another|contact|all))*$"
Local $sString = "all" & @CRLF & _
"contact" & @CRLF & _
"another" & @CRLF & _
"all,contact" & @CRLF & _
"contact,all" & @CRLF & _
"all,another" & @CRLF & _
"another,all" & @CRLF & _
"all,another,contact" & @CRLF & _
"all,contact,another" & @CRLF & _
"contact,all,another" & @CRLF & _
"contact,another,all" & @CRLF & _
"another,all,contact" & @CRLF & _
"another,contact,all" & @CRLF & _
"" & @CRLF & _
"all,all" & @CRLF & _
"contact,contact" & @CRLF & _
"all,contact,all"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")