import re
regex = re.compile(r"^(?!.*\b(\w+)\b.*\b\1\b)(?:another|contact|all)(?:,(?:another|contact|all))*$", flags=re.MULTILINE)
test_str = ("all\n"
"contact\n"
"another\n"
"all,contact\n"
"contact,all\n"
"all,another\n"
"another,all\n"
"all,another,contact\n"
"all,contact,another\n"
"contact,all,another\n"
"contact,another,all\n"
"another,all,contact\n"
"another,contact,all\n\n"
"all,all\n"
"contact,contact\n"
"all,contact,all")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")