re = /^(?!.*\b(\w+)\b.*\b\1\b)(?:another|contact|all)(?:,(?:another|contact|all))*$/m
str = 'all
contact
another
all,contact
contact,all
all,another
another,all
all,another,contact
all,contact,another
contact,all,another
contact,another,all
another,all,contact
another,contact,all
all,all
contact,contact
all,contact,all'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end