$re = '/^(?!.*\b(\w+)\b.*\b\1\b)(?:another|contact|all)(?:,(?:another|contact|all))*$/m';
$str = 'all
contact
another
all,contact
contact,all
all,another
another,all
all,another,contact
all,contact,another
contact,all,another
contact,another,all
another,all,contact
another,contact,all
all,all
contact,contact
all,contact,all';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);