const regex = /^(?!.*\b(\w+)\b.*\b\1\b)(?:another|contact|all)(?:,(?:another|contact|all))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\b(\\w+)\\b.*\\b\\1\\b)(?:another|contact|all)(?:,(?:another|contact|all))*$', 'gm')
const str = `all
contact
another
all,contact
contact,all
all,another
another,all
all,another,contact
all,contact,another
contact,all,another
contact,another,all
another,all,contact
another,contact,all
all,all
contact,contact
all,contact,all`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}