use strict;
my $str = 'all
contact
another
all,contact
contact,all
all,another
another,all
all,another,contact
all,contact,another
contact,all,another
contact,another,all
another,all,contact
another,contact,all
all,all
contact,contact
all,contact,all';
my $regex = qr/^(?!.*\b(\w+)\b.*\b\1\b)(?:another|contact|all)(?:,(?:another|contact|all))*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}