#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*b bb[\s\S]*d dd.*$"
Local $sString = "aaa aa a" & @CRLF & _
"bbb bb b" & @CRLF & _
"ccc cc c" & @CRLF & _
"ddd dd d" & @CRLF & _
"eee ee e" & @CRLF & _
"fff ff f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")