// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*b bb[\s\S]*d dd.*$").unwrap();
let string = "aaa aa a
bbb bb b
ccc cc c
ddd dd d
eee ee e
fff ff f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}