$re = '/^.*b bb[\s\S]*d dd.*$/m';
$str = 'aaa aa a
bbb bb b
ccc cc c
ddd dd d
eee ee e
fff ff f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);