using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*b bb[\s\S]*d dd.*$";
string input = @"aaa aa a
bbb bb b
ccc cc c
ddd dd d
eee ee e
fff ff f";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}