const regex = new RegExp('^.*b bb[\\s\\S]*d dd.*$', 'gm')
const str = `aaa aa a
bbb bb b
ccc cc c
ddd dd d
eee ee e
fff ff f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}