#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)".+?""
Local $sString = "<"dd1242__dd"> " & @CRLF & _
"" & @CRLF & _
"<book navtitle="CHAPTER_7_GIFT_POLICY" href="../contents/CHAPTER_7_GIFT_POLICY.htm" format="html" processing-role="normal">" & @CRLF & _
"" & @CRLF & _
"ljkasdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")