import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\".+?\"";
final String string = "<\"dd1242__dd\"> \n\n"
+ "<book navtitle=\"CHAPTER_7_GIFT_POLICY\" href=\"../contents/CHAPTER_7_GIFT_POLICY.htm\" format=\"html\" processing-role=\"normal\">\n\n"
+ "ljkasdf";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}