import Foundation
let pattern = #"".+?""#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<"dd1242__dd">
<book navtitle="CHAPTER_7_GIFT_POLICY" href="../contents/CHAPTER_7_GIFT_POLICY.htm" format="html" processing-role="normal">
ljkasdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}