#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(@url)([\s]=[\s]*)(?:')(.*)(?:')(?:;)"
Local $sString = "@url = 'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer';" & @CRLF & _
"@header.add('secret','koutty2222Efdxaaalghteqjkhy')" & @CRLF & _
"" & @CRLF & _
"var @collectionitems = @collectionitem('value1')" & @CRLF & _
"var @timeItems = {20221003, 20221004}" & @CRLF & _
"" & @CRLF & _
"@block.loop(@item1 in @collectionitems, @item2 in @timeItems)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"@block.end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")