import re
regex = re.compile(r"(@url)([\s]=[\s]*)(?:')(.*)(?:')(?:;)")
test_str = ("@url = 'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer';\n"
"@header.add('secret','koutty2222Efdxaaalghteqjkhy')\n\n"
"var @collectionitems = @collectionitem('value1')\n"
"var @timeItems = {20221003, 20221004}\n\n"
"@block.loop(@item1 in @collectionitems, @item2 in @timeItems)\n\n\n\n\n\n\n\n"
"@block.end")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")