import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(@url)([\\s]=[\\s]*)(?:')(.*)(?:')(?:;)";
final String string = "@url = 'https://asfasfasfasfkjsfasdfkasjadfajsjkfd.com/licensekey=fqiwerqwer';\n"
+ "@header.add('secret','koutty2222Efdxaaalghteqjkhy')\n\n"
+ "var @collectionitems = @collectionitem('value1')\n"
+ "var @timeItems = {20221003, 20221004}\n\n"
+ "@block.loop(@item1 in @collectionitems, @item2 in @timeItems)\n\n\n\n\n\n\n\n"
+ "@block.end";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}